以太坊君士坦丁堡升级因“可重入”漏洞延期  bishijie.com

2019-01-16 10:17:40 以太坊曹影

据PeckShield消息,今天凌晨,以太坊君士坦丁堡代码突然爆出“可重入”漏洞,该漏洞可以用来攻击相关合约修改用户余额或其他关键变量。PeckShield安全人员初步分析发现,在分叉之前一个存储操作至少需要5000gas,这个是远超缺省转账激励的2300gas。但分叉后一个存储只需200gas,这个造成了现有合约再处理转帐时候,如调用了攻击者合约,可以用来修改调用者合约的内部变量,其中可能包括账号余额等。由于该漏洞,以太坊君士坦丁堡升级延期,具体的升级时间将在周五的下一次核心开发者电话会议选出。

阅读原文
标签:漏洞 以太坊 升级 君士坦丁 合约 延期